Azure Network issue has been addressed and we are monitoring the results.
Posted Mar 19, 2025 - 01:33 UTC
Identified
Our team is actively monitoring the situation while awaiting further updates from Microsoft. We will provide additional updates as we receive more information.
Posted Mar 19, 2025 - 00:39 UTC
Investigating
We are currently investigating an issue originating from Azure Network affecting the US East region.
--- From Azure: Service: Network Infrastructure
Region: East US
After further investigation, we determined we are still working with our providers on fiber repairs, however, no further impact should be experienced as previously communicated. We apologize for the inconvenience caused.
What happened?
Between 13:09 UTC and 18:51 UTC on 18 March 2025, a platform issue resulted in an impact to a subset of Azure customers in the East US region. Customers may have experienced intermittent connectivity loss and increased network latency sending traffic within as well as in and out of Azure's US East Region.
Current Status: We identified multiple fiber cuts affecting a subset of datacenters in the East US region. The fiber cut impacted capacity to those datacenters increasing the utilization for the remaining capacity serving the affected datacenters. At 13:55 UTC, we began mitigating the impact of the fiber cut by load balancing traffic and restoring some of the impacted capacity; customers should have started to see service recover starting at this time. The restoration of traffic was fully completed by 18:51 and the issue was mitigated. While fixing fiber will take time, there should be no further impact to customers as impacted devices are isolated and the traffic is shifted to healthier routes. Further updates will be provided in 6 hours or as events warrant.
Posted Mar 18, 2025 - 23:55 UTC
This incident affected: myDevices Dashboard, Console Portal, Authentication & SSO, Integrations, API Service, Streaming, Device Connectivity, Device History and LoRaWAN Network (Azure - US East).