Degraded Notifications Issues

Incident Report for myDevices, Inc

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:55 UTC

Identified

The issue has been identified.
Posted Oct 20, 2025 - 17:07 UTC

Investigating

Due to ongoing AWS issues, Twilio and Sengrid are experiencing degraded performance. Hence, you may notice delayed SMS and Email notifications or unsuccessful deliveries.
Posted Oct 20, 2025 - 17:07 UTC
This incident affected: Notifications (E-mail Alerts, Twilio SMS).